From 2562c734da6da6bd57ef6a2179a2eb22dda7b126 Mon Sep 17 00:00:00 2001
From: John MacFarlane <jgm@berkeley.edu>
Date: Thu, 13 Nov 2014 22:11:38 -0800
Subject: Compile with -fvisibility=hidden.

We'll mark public functions as "default".
---
 src/CMakeLists.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'src/CMakeLists.txt')

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3c0f610..3157bd1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -89,7 +89,7 @@ if(MSVC)
     set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /W4")
   endif()
 elseif(CMAKE_COMPILER_IS_GNUCC OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
-  set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -std=c99 -pedantic")
+  set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fvisibility=hidden -Wall -std=c99 -pedantic")
 endif()
 
 if($ENV{TIMER})
-- 
cgit v1.2.3